Pending Review

Arch Linux Support

Andrew Speer 3 years ago updated by Julian 7 months ago 9

Create support for systemd exclusive Linux variants such as Arch Linux.

Software fails to install due to not utilizing init.d for services.

I had the same issue last night trying to get it working on Manjaro Linux, which is Arch based.  I tried a few different things, and was ultimately able to make it work, but it was ugly.  I first downloaded the .deb package, installed dpkg, then did a dpkg -i on the deb package.  That kept failing on the init.d and lintian folders, so I manually created them.  It then completed, but didn't run the postinst script due to the java5-runtime dependency not being there, even though java was installed.  I extracted and ran the postinst script, and was able to manually run the /etc/init.d script.  It worked great, but of course won't start automatically like that.

I am thinking of creating a systemd unit file and maybe a script/pkgbuild to just get the necessary parts of the .deb and automate this process.  Unfortunately because the deb files are specific to each instance, I don't think I can just put it in the AUR.  I can put it on GitHub if people are interested, though.

Hey - came across this thread because I too couldn't get it easily installed on Arch. Would be very happy to refer to your github repo for instructions on getting this installed. I'm currently running on Garuda Linux, which is arch-based.

I made a first pass at this here:


In case it filters the URL go to github and look for me (Kelderek) and the repo is connectwisecontrol-arch.  Let me know if it works for you!

I have an issue when trying to install Connectwise on arch from script: line 280: InstallPackageFile: no such command. Please add support to Archlinux or give some solution :) Thanks! 

The script won't work on Arch for a couple reasons.  First is the error you are seeing which happens because it checks for a supported package format (deb or rpm for Linux, pkg for Mac) and it doesn't properly error check if it can't find one of those.  The second is that it relies on the old init scripts instead of systemd, so even if the files got installed it wouldn't start on Arch, which is systemd only by default.

It would be great if ConnectWise added Arch and systemd support, but in the meantime if you go to my GitHub link right above your post you can find my workaround for Arch. You point it to your deb file and it will repackage it for pacman and install it with a systemd service.

Thanks, i agree. ConnectWise should add Arch support cause it was working when it was using jnlp files. Your solution wont work for me cause im using Wayland

If you just want your computer using Wayland to control a remote system, jnlp files still work.  Java Web Start (jnlp files) are deprecated starting with Java 11, so you have to have jdk8-openjdk and icedtea-web installed, then when joining a session choose the SystemProfiles / Default / WebStartDirect to get the jnlp file.  If you have multiple java versions installed you will have to either run "sudo archlinux-java set java-8-openjdk" to set 8 as your default, or setup icedtea-web to use the right JVM by running /usr/share/icedtea-web/bin/itweb-settings, going to JVM settings and "Browse for JVM for IcedTea-Web".  I picked /usr/lib/jvm/java-8-openjdk and when it tried to validate it found bin/java and complained that it couldn't find lib/rt.jar but worked anyway and I could open jnlp files no problem.

If you want your machine to be controlled then yes it won't work because ConnectWise doesn't support Wayland.  As I understand it the Wayland security model doesn't currently allow for that kind of remote control as a system service at all.  The ConnectWise agent still connects so you can run shell commands through the Control dashboard, but you can't see or control the remote screen.

Update on the "Browse for JVM for IcedTea-Web": I found that the path /usr/lib/jvm/java-8-openjdk/jre makes it happy on all counts, including lib/rt.jar so that is probably a better path to use

Please add support for Arch Linux! I would love to access my clients from my Arch System!