Allow remote printing, that once turned on manually, stays on after disconnects, until disabled manually

david 5 years ago updated by Ed Deiaco-Lohr 2 years ago 14

I have clients that use the remote printing feature of ScreenConnect daily, but after updating to v19.0, remote printing now needs to be toggled manually each time the host connects. I would like it if once remote printing is enabled then it stays active even after the host disconnects, unless disabled manually.


This is also a change that I would really like to see come back. This is how it behaved in the old version, at least an option to change the behavior would be sufficient. 


We have come to rely on that being on automatically.  We have a number of clients that are frustrated now because they have to remember to turn printing on each time.  It would be nice to be able to choose what state the session should start in. 

please add print lock function what is existed already on local's printers properties but via remote printing session is not accessible

when you use printer Lanier mp 4054 pcl 6 locally "Lock print" function works fine, but when you do 'screenconnect remote printing', you see your printer, you can print, but that function gets lost, only basic printer settings are here. It created chaos - all print jobs got messed up between office users, clients delayed, what is not good for business, plus, actually it's a big MINUS, privacy gets broken. Please fix it A.S.A.P. 

If we use LogMeIn service - all printer's options and setting are translated, so there is no difference between locally and/or remotely printed job. But with you guys, it doesn't work and you positioning your product as the best. 

See below, "lock print" accessible locally:

And see below, it's gets lost if the same printer connected for remote print (see how much you got lost!):

and yes, users very upset that after every reconnect they have to turn on again "Allow remote printing" again and again.


in your second photo . if you goto the advanced tab . then change the driver from pcl5 to the driver of your printer in the drop down . then click ok . you will see same as your first photo .

but for some reason screen connect does not remember and you have to do it each time you reconnect to machine ..

pain . 


Definitely need this feature. We access dozens of client PC's on a daily basis and print reports to our in-house PC for record keeping. It's annoying to turn it on for each and every client. 

Chiming in to say we would very much like this as well.

Definitely would like to have an option to keep it automatically on have some sort of plugin to have it activated on certain users only

Agreed, we need a way to keep remote printing active all the time for certain users.

There is a setting for this already depending what version your server is on in the Advanced Configuration Editor extension. Once you install it you go to Admin > Advanced > Web Configuration > Settings. You will see a checkbox to have remote printing default to always being on.

Jake, we need to be able to activate this only for certain users. Your recommendation turns it on for all users all the time. 

Perhaps there could be a role assigned to certain users that would automatically enable remote printing for only the users with that role applied. 

We would like to see this feature as well, and not just with remote printing but other features like blanking guest monitors, automatically match screen resolution, etc. With ITSupport 24/7 integration we do not use the "screenconnect portal" and there are no options to enable or disable automatically. It's really frustrating for our users to have to click options every time they connect. There is the app.config file, but it's limited.


Hi Charwerth,

The above request has already been fulfilled. Please install 'Advanced Configuration Editor' on your instance (if not installed already) then go to Web Config > Quick Settings to make the changes.

For more info please click the link.

Hope this helps !!

This does not apply to us. Not everyone has access to the extensions webstore. As I said, this is with ITSupport 24/7 integration but specifically with ConnectWise Control.

As Usual, this thread started 3 years ago and still hasn't been fixed.  The ADMIN fix sets the default for ALL users, not individual.

I work in office and remote.  I have to remember to activate remote printing each time.  If I don't I print something, realize I have to activate, wait until the printer populates and then print again.  How i miss LogMeIn :(