+9
Pending Review

AMD raspberry pi support

Ian L-F 3 years ago updated by Michael Thompson 4 weeks ago 22

I'd like to see you folks support Ubuntu on a Rasperry Pi

We'd also find this useful.  We have a fleet of Pi's running Raspbian out on customer sites. We can rarely connect inbound to the network they're on, but they can connect out.  We need to be able to access GUI on the Pi for remote support and diags. 

I'm running a few desktop web browser/printing kiosks with Ubuntu 20.04 for our warehouse on Raspberry Pi4s, which is arm64/AArch64, so a deb built for this platform would be very useful.  I don't know what your build platform is, but it should be possible to setup build environments with docker/qemu or other virtual machine systems. 

Kernel "uname -a": Linux localhost 5.8.0-1016-raspi #19-Ubuntu SMP PREEMPT Tue Feb 9 20:12:43 UTC 2021 aarch64 aarch64 aarch64 GNU/Linux

I was able to get the java based remote access agent installed with the ConnectWiseControl.ClientSetup.sh which wanted java5-runtime as a prerequisite, which was satisfied with installing openjdk-8-jre I was able to install and connect to the remote machine.

Can you provided step-by-step instructions used to get this working?

+1

The full details got held for moderation, and might appear later.

I went into ConnectWise Control

  • click Build
  • Select Mac/Linux (.sh)
  • Copy URL
  • ssh to Raspberry Pi 4 running Ubuntu 20.04
  • wget "URL" -O ConnectWiseControl.ClientSetup.sh
  • chmod +x ConnectWiseControl.ClientSetup.sh
  • sudo apt install -y openjdk-8-jre
  • sudo ./ConnectWiseControl.ClientSetup.sh

For the support session client, I tried downloading it and it comes in jnlp format, and so the icedtea-netx package is required to run it, but I didn't try it, I was more interested in the remote access client.

  • sudo apt install -y icedtea-netx
  • javaws ConnectWiseControl.Client.jnlp

I can confirm that this works.  I appreaciet you spelling out the steps.  I am using xubunutu as the GUI and ConnectWise is slow as hell.  I take it I've maxed out the possibilities with the box and there are no more tweaks?

+2

I run control on hundreds of Pis (raspbian though) without issue.

As noted above you will need java. If you want UI (and not just commands) you will need to either have a screen or modify some screen options.

Slow, sure. Working, yes.

Martin,

Specifically, what screen options?  For headless.

+2

Set Headless Resolution:
sudo nano /boot/config.txt
Copy below to bottom of file, save and exit
# Set headless video resolution
hdmi_force_hotplug=1
hdmi_group=2
hdmi_mode=47
# (above is 1440x900@60Hz)
# hdmi_mode=16 (1024x768@60Hz)
# hdmi_mode=39 (1360x768@60Hz)

If you have a Pi 3B+, we add 1GB to the swapfile. This seems to resolve memory exhaustion issues over time. I've been adding this to Pi 4 units as well, just in case.
sudo nano /etc/dphys-swapfile
CONF_SWAPSIZE=1024

(Not mine, some copy and paste I found online that works for me)

Thank you for sharing this!

Anything else you are doing?  Its refusing to display for me still with these settings.

+1

Headless still does not work for me.  I have an open development ticket with the team, please push them on this:

SCP-37140
Blank screen when connecting to Raspberry Pi 4b

is there any update on that topic? I also have a few pi4 with ubuntu 20.04.02 LTS 64bit and connectwise on them... but it seams that I only get blank screen. Even doh fb test script gives me out following output:

gcc not found. Installing gcc.
Installed gcc successfully.
------------------------------------------------------
Details for Frame Buffer /dev/fb0:
Width : 1024
Height : 768
Stride : 4096
Bits Per Pixel : 32
Red Offset : 16
Green Offset : 8
Blue Offset : 0
Red Length : 8
Green Length : 8
Blue Length : 8
------------------------------------------------------
Uninstalling gcc.

No, but please open a case with the support and refer to SCP-37140

I have been pushing this but getting nowhere.  Its become a real pain.

Are you running an 32bit or 64bit os on the pi?

I've tried both.  But basically, it will be 64bit we need.

I've followed the instructions and successfully installed the agent on them, however I have a couple that worked for a few days then have been offline ever since.  I can remote to them via VNC and i've re-run the script, but still offline, any ideas to try? Thanks

We would also find this useful, we have a fleet of PIs on our production floor and it would be great to be able to do remote support.

We've started to have the need to do this and we are also getting a blank screen on connect. 

Just wanted to add something here to this.  I got this to work today.  I had to open a case with CW they did not directly hepp me but they did tell me I needed to disable wayland.  In short you have to disable WAYLAND.  To do this on the Raspberry Pi you need to do the following after it is installed. I was running Raspberry Pi OS in full disclosure.

sudo nano /etc/lightdm/lightdm.conf

uncomment the line that says #xserver-command=X

then make it xserver-command=X -core

sudo systemctl restart lightdm

sudo systemctl restart [CWSERVICENAME]

It worked for me!

Seeing >4k views on this leads me to believe we are not the only ones that want this functionality. I'm using a competitors Remote Access for now since i don't like having to hack my way through making a product work. Connectwise - Please get on this as soon as possible. 

PS - I tried Neadom suggestion and it did NOT work for me.

I'm running Raspian installed today. I have gotten this to work on Ubuntu and other distro's just not raspian.