+30
Pending Review

Support for connecting to a headless endpoint (windows computer without a monitor plugged in).

joelcrburgess 5 years ago updated by Pablohere 2 months ago 31

Currently there is no support for connecting to a headless endpoint (windows computer without a monitor plugged in). This is a big problem, as we are in the middle of moving from Bomgar to Control and now we realize that we can't support many of our client's servers or even Win10 computers who are headless. Even though the client has no monitor connected, we should still be able to see the Explorer GUI, other remote support apps certainly can do this. This is a HUGE feature-lack.

Hi joelcrburgess, 

Wanted to pass along our troubleshooting guide for blank screens. We are continuing to investigate fixes for these blank screen issues. Can you please provide relevant information about your servers, version number, etc.? 

Thanks, 

Caitlin 

Many of the servers (and some desktops) we support have no monitor or KVM plugged into them and we don't have this problem.  Your problem probably lies elsewhere - such a video card driver or some other cause of blank screen.  To troubleshoot - try changing a computer to the MS basic video adaptor driver, then reboot and see if it's resolved.

Hi, got exactly the same issue with Win 10 headless, latest version (released 10/2/19 US date format), self hosted server. We dont have this issue with Server 2012 r2, 2016 or 2019. 


We've tried blanking guest monitor, makes no difference.

Tried rebooting into safe mode, makes no difference

Just ran into a problem again where I cannot remotely control a headless machine. It's connected to a TV. That is turned off.

I had to download and install TeamViewer to get my work done. Which was a challenge given that half the screen elements wouldn't display.

You guys are pestering me to renew my subscription but you seem uninterested in addressing problems with headless access which is EXTREMELY common.

This is basic functionality. I shouldn't have to use a competitors product because yours hasn't seen significant updates in years.

I'm tired of dealing with it. 

I'm not renewing.

Old post, but had this issue and thought I'd give some insight. Turns out, no graphics card installed/onboard = no joy. Headless in this case means not only no monitor, but no graphics card either. You don't have to plug a monitor into the card, but one has to be in the machine for Connect Control to show a screen. So, those running headless saying they don't have an issue are either machines with onboard graphics, or a card inside.

Having trouble with a Precision Workstation with a Quadro 960 card in it. Pull the monitor and the remote session just craps on itself. This is really ridiculous in this day in time.

+2

Yes. They don't care, and apparently won't be fixing it. It's a very old problem at this point.


I stopped renewing my self hosted maintenance because of it. Well, that and the terrible mobile app interface.

Here's a hardware work around. You can search for various resolutions and pack sizes - https://smile.amazon.com/fit-Headless-Emulator-FUERAN-Resolution-Adapter1920x1080/dp/B093Q2DPKW

+2

Just started running into this issue with a number of Windows 11 Desktop PC's ..well similar ... if the monitor (or monitors) plugged into the Desktop PC is turned OFF - I get a grey screen when I connect via ScreenConnect ... and it's clickable, i.e. I can actually click the desktop elements of the client PC, just not getting the desktop showing to me on my end.

Reboot - doesn't fix it
Blank Guest monitor, then unblank it again - doesn't fix it
Re-installed video card (including my own nVidia 2060 at home!) - doesn't fix it
Ask someone to run over and physically turn the attached monitor on and BAM! ScreenConnect works fine. 

This is getting a tad annoying

+1

ConnectWise hasn't invested any effort into improving ScreenConnect since they've bought it. Well, that customers want anyway. They've spent money pushing their subscription and looking for ways to upcharge.

You're going to have to switch products if you want a working remote support solution. This issue has long since been addressed by TeamViewer, Splashtop, and others. (Splasthop has a "virtual monitor" driver, etc.)

I still keep my ScreenConnect server running as a backup method to connect. But I gave up and switched away. I just saw no reason to keep paying for maintenance when they were refusing to maintain the damn thing anymore. 

Once Connectwise buys anything the product lacks any useful development and basically dies a slow death.

This issue just popped up on 2 exact builds...

MSI B550 motherboards with AMD 5600G cpu

If no monitor is plugged into the board, screen connect control just shows the screen, but nothing is clickable at all.

8-8-22

Connectwise, any news on when this is going to be fixed? This has been an issue for a considerably long time now, even longer than this post!

+1

It's been over 4 years since the thread was started - safe to assume they don't give a **** ... 

Support for headless machines is outlined in this article:
Connect to a headless Windows machine - ConnectWise

Generally if there is a video card output we will be able to capture the screen, in some cases where video is outputting a dummy plug may be needed.

+1

Why would you think that is acceptable?

Especially given the problem happens when people close laptop lids.

And your competitors have solved it with "virtual" video cards?

Complete BS telling people to plug in hardware adapters to do remote END USER support. Ignores that the problem is real or significant. Dismisses our concerns.

Which is why I stopped renewing my self hosted maintenance. Doesn't seem worth paying for when there's no customer focused development being done. Why pay for a product that isn't meeting our needs when solid alternatives exist?

Well, after looking for a viable solution, it looks like I'm going to cancel my subscription. This has become a big deal for me. I manage exhibits all over the country and many of the things I need to do are done after hours. Introduce control systems such as AMX/Crestron/OvRC or the like that can kill power to displays to save power per LEED requirements, I'm stuck getting the work I need to get done. While I can wake machines, often the control for powering things on like displays isn't granular enough with control systems. Or if it was, you would be powering both devices on and off and not able to take advantage of WoL features in AMX/Crestron. So what you have with CWControl simply a Managed Service Providers helpdesk tool. It's too bad. Been with CW for nearly 3 years and I'm hitting a wall with this issue. With nearly 100 client computers and two thirds of them inaccessible under a headless condition, it's time to jump ship. 

Other MSP tools have addressed the problem, because it's a hard stop when it comes up.

So, no, I wouldn't rate it as "simply a Managed Service Provider helpdesk tool". Because it fails at that. At least as a primary tool. I have kept my perpetual self hosted going as a backup to the ones I use daily. Nothing is perfect, everything breaks at some point.

+1

@swhite, this doesn't solve the problem if the monitor / TV is simply turned off.  There is a similar feature request going for a virtual display adapter (the way LogMeIn does it).. that would solve this issue as well that has had no active comment from CW.

The screen is displayed correctly and presents me with the lock screen but is unresponsive in my case. Sending Ctrl Alt + Del doesn't progress any further.

+1

It's not displaying correctly when it doesn't show video updates.

You might want to try entering your credentials blindly, disconnecting, reconnecting, and seeing if you see the desktop. But you'll be stuck there. Good luck trying to use the start menu or Windows settings.

This is an old thread. They are not going to fix this. They don't see it as a problem worth spending money to resolve. They've been focused on finding ways to charge more since ConnectWise bought ScreenConnect.

reboot the end point machine with out a monitor plugged in and it will work ok to access remotely without a monitor left hooked up

Most of the time with the ones that have problems, it will not.

You will see the Windows desktop. But try opening settings or using the start menu and it fails.

The situations it fails are so common that it's not a usable product for an MSP.

You just cannot count on an end user keeping their laptop lid open.

Again - this doesn't address the point that you cannot 'see' the remote computers screen in ScreenConnect if the monitor is simply turned off. 

Eg, right now my Windows 11 box at home has its monitors turned off but is left running 24/7. If I remote into it via ScreenConnect right now I'll get a Grey screen on this end. I can even click randomly on the grey and it will click and run button and icons on the actual PC and launch stuff. Get someone to physically turn the monitor ON and hey presto - remotely display works fine in ScreenConnect.

For the same reason - I have to leave my work monitors on 24/7 so I can remote into my work machines if I need to from home/working elsewhere. 

These are not 'Headless Machines'. They already have video cards and monitors plugged in ... ScreenConnect just displays a Grey Screen on Connect to them IF the monitor is turned off on that device.

This issue only started a few versions ago, worked fine with monitors off before then.

1) There are at least 3 implementations of ScreenConnect and this thread easily confuses them all. Automate, screenconnect.com (subdomain), and the adhoc client (subdomain of hostedrmm.com).

2) Having used these services in a MSP environment I know Automate will work with a headless machine no problem. The adhoc client I have not tested. screenconnect.com will have issues.

3) With screenconnect.com's agent, I was able to initially use the service and get into a headless PC. This PC has a ASUS B650E-E motherboard with onboard video and a GPU installed as well. Based on the default screen resolution of the window, it must be pulling the onboard video up. It has a glitch where most display changes related to Explorer will not update on the screen. For example if you click the start button, the menu will not appear. But if you click in the search bar, the window appears. If you right click on the task tray, you will see the options for Task Manager or Taskbar Settings (win11), but if you click on one of them, you won't see the window appear. Fix: send a CTRL + ALT + DEL after every request, hit esc to cancel, and the window refresh will appear. However, this won't work for right clicking task bar icons so you cannot unpin them. I ran into a UAC firewall issue, the screen locked up (no cursor or window updates including Ctrl + Alt + Del). So I rebooted. Now the mouse won't work so I can't get back into the machine. It takes me to the clock display, then I hit Ctrl + Alt + Del and it shows the login prompt, but I can't click into it to put a password. It appears that a ghost monitor device would be best. Will test with a monitor for now and see what happens.
Edit: hooking up a monitor fixed the GPU problem as expected. But mouse and keyboard was still unresponsive until I plugged in a mouse and keyboard.

Other notes: Remember to bypass consent, set power settings to not sleep, and disable UAC (if not on a domain).

Not sure what you mean by "3 implementations of ScreenConnect". It's all the same ScreenConnect agent regardless of where the ScreenConnect server is hosted. The only differences in agents are between releases of the product (e.g. 23.2 vs 23.3)

The SC bundled with Automate is the exact same build as the standard self-hosted build. The license comes via the LabTech (Automate) license. Nothing special here except some common config options which are used to tie SC to LT.

However, the hosted product while the same software build has some different server config (which CW are annoyingly refusing to support self-hosted using) which allows both web and relay to use the same port (443 I think). It's the same code, but with some non-standard config hacked into it which makes it different enough to be worth noting.

Adhoc is just a license. The software is the same.

+2
We found running this in Powershell will fix the issue. You can connect to backstage to run the powershell commands, and then swap to the console and the display should be responsive.

mkdir C:\temp
cd C:\temp
Invoke-WebRequest https://www.amyuni.com/downloads/usbmmidd_v2.zip -O usmb.zip
tar -xf .\usmb.zip
cd .\usbmmidd_v2\
.\deviceinstaller64.exe install .\usbmidd.inf usbmmidd
.\deviceinstaller64.exe enableidd 1

This worked great for me (July 2023). I needed a headless connection and these steps got me up and running. If you're spooked about downloading a random zip, here's there root site:
https://www.amyuni.com/downloads

and here's another set of instructions describing the same fix:
https://www.amyuni.com/forum/viewtopic.php?t=3030

Thank you for posting your fix!

Everything was good until I got to here.

This worked ok

cd .\usbmmidd_v2\



This Failed. just say Failed.

.\deviceinstaller64.exe install .\usbmidd.inf usbmmidd
.\deviceinstaller64.exe enableidd 1

Ron try using this command instead for the first line:

Cmd.exe /c deviceinstaller64 install usbmmidd.inf usbmmidd